Jump to content

Recommended Posts

Hi Alex,

 

I couldn’t remember at first, but checking the Kitlocker, yes they’re kit 921.

 

At the time of planning I hadn’t realised the diversity of the CANMIO and would probably have used them on the scenic boards as well as the fiddle yard.

 

Cheers,

 

Mark

Link to post
Share on other sites

Morning All,

Finally, a bit of time for modelling and a little bit of progress.

Some time ago I assembled a small test board for the CANMIOs, but stumbled at the firmware loading stage. This evening I had a chance to hook up the laptop with all the necessary bits and have another go at it:

 

20190217_202557.jpg.c1ddbb32933f315f6e92b974d955a955.jpg

 

At the top there are two lengths of track for occupancy detection, the tracks being connected to the dual block detector (lower left); the latter is just the MERG PMP7 duplicated on one board. This then feeds into the CANMIO at the lower right. For output testing I will use the two servos just above the CANMIO.

So the "little bit of progress" is that the Green LED on the CANMIO now illuminates, and when the board is switched into FLiM mode (basically computer interface mode) the Yellow LED flashes, indicating that it is ready to talk to a computer. Okay, so it really is only a little bit of progress, but a fairly big step towards getting the electronics up and running. The downside now is that the laptop, or at least the software used to program the board (MERG FCU) doesn't see it.

I have a second CANMIO now with the firmware loaded (would have loaded the rest if I could find them!) which displays the same issue, so I think i now need to look at the interface side of things, but it does seem to be forward progress!

Cheers,

Mark

 

 

Oh, and how do you resize images so they don't overwhelm a post?

 

 

  • Like 3
Link to post
Share on other sites

Morning All (as it will be by the time I hit the ‘Post’ button!)

 

Bit more progress Friday; I dug out the remaining PICs from my electrics box and got the Firmware loaded to them all.

 

Next was to look into why the MERG FCU wouldn’t talk to the CANMIOs; after connecting directly to a CANUSB4 - bingo! Must have a problem with the CBUS connection to the Hub which contains my original CANUSB. So now when I put the CANMIO into FLiM I get the dialogue box pop up in the FCU.

 

Next hurdle - figure out how to program them in the FCU, but at least that’s just a learning exercise.

 

Cheers,

 

Mark

Edited by pelhama
Link to post
Share on other sites
  • 1 year later...

Afternoon All,

 

Where's the time gone, over a year since my last post!

 

While on Furlough leave, I decided to build a small test track for running stock in, having seen Graham's (shanks522) new layout build:

 

 

 

My version can be found below:

 

 

 

This will at least allow my stock to 'stretch its legs' a bit whilst waiting for the bigger layout!

 

Cheers,

 

Mark

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.