Jump to content

Recommended Posts

Hi Friends 

 

I have recently Purchased a Dapol Class 29 to which I fitted a Dapol Imperium 21-pin decoder...the locomotive was running well for a week or two but now it has developed a problem. While running it stops and the lights remain on but at half intensity. A faint sound is heard from the motor. Nudging it sometimes causes it to move again but then it stops at another location...

 

i have tried covering the decoder with insulation tape lest there is some Unwanted contact With the main board but this has not solved the issue. The decoder fits snuggly on to the pins. I do not see any short circuit effects - rather a poor contact somewhere. I am not sure what this may be. It must be electrical or dirt related although I haven’t been able to see this. 
 

please advise. 

Link to post
Share on other sites

If the 29 was my loco, as the first step I would remove the decoder,  converting back to plain DC and test for satisfactory running as a analogue 12V DC loco

Edited by Pandora
Link to post
Share on other sites
  • RMweb Gold

The Imperiums aren't the most high quality decoders around so I'd agree with the above, remove decoder and test on DC and see how it goes.

If its fine on DC I'd get a £20 Zimo decoder to replace the Imperium.

 

If its not fine on DC then back to the shop it goes for replacement.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.