Jump to content

Recommended Posts

Ive had my Z21 for almost a year now, and I love it. Its been a real power house for the oo garden railway, and is by far the best controller I have used.

 

However, getting a traintech DS3 3 aspect light to work is proving hard, even for my considerable IT know how.

 

Ive tried so many different ways, to no avail. The 2 aspect lights work fine, but thats because they only require a single address. The three aspect requires 2. One for red & green, a 2nd for amber. No matter what I try, it fails

 

I can get it to work in config, with the following settings  (brackets indicate the green selected box)

 

TEST       ADD1       ADD2

 

GREEN    (1)  0          1    0

 

RED          1   (0)        1     0

 

AMBER     1     1         (1)    0

 

So this works great in config, but if you move back a page, and then forward again, these settings dont stay fixed. It appears that the config is only save when a total of 6 boxes are select, 3 for address 1, and 3 for address 2

 

as an example

 

TEST       ADD1       ADD2

 

GREEN    (1)  0          1     (0)

 

RED          1   (0)        (1)     0

 

AMBER     1     1         (1)    0

 

Step a page back, and forward again, and these settings have taken, but of course they mean diddly in terms of getting the DS3 to actually work

 

As I understand it, address 1 is the fwd and reverse attribute that switches red and green

address 2 is the same, but for amber...

 

So it should be straight forward.

 

It will be a real shame to have to relegate this 3way down to a basic red green 2 way just because I cant fathom out the matrix used for the controls.

 

 

 

 

 

Share this post


Link to post
Share on other sites
 

Ok as a result the modular discussion I've looked at splitting the supply off my Uhlenbrock booster using circuit breakers to create three separate track BUS to run a large layout. Still waiting confirmation that the circuit breakers suggested are ok with the uhlenbrock booster.

 

Now I know I can use around 10 wireless devices without too much risk but I'm also looking at how people could bring their own compatible throttles. I see from the pdf off their website, link below, that Lenz throttles are ok via the X-Bus. Now the Z21 doesn't have an X-bus set of accessories so can I use any make or would it have to be something like Lenz's own cabling and throttle panels?

 

http://www.z21.eu/content/download/1065/12755/file/Z21_XBUS_en.pdf

 

Z21 FAQ's

http://www.z21.eu/en/FAQ-Support/FAQs

Edited by PaulRhB

Share this post


Link to post
Share on other sites

Good to hear it works ;)

 

This is the rough setup I'm thinking of to give options, I'm still waiting to hear on the compatibility of the components from Roco and others so if anyone can help it'll be much appreciated.

 

post-6968-0-02775200-1406318082_thumb.jpg

Share this post


Link to post
Share on other sites

 

(PS: I also have a question open at Roco, 2 weeks en-counting. Could be the holiday season, I've noticed Piko has shut its factory for 3 weeks now)

Ah yes the season of shutdown, no prob to me as it's going to be next year before this is an issue.

Share this post


Link to post
Share on other sites

Thanks for the link Paul. However, I think you may have started at the wrong end of the problem: it's not for Roco to determine if a product is compatible with their DCC system. It's DCC Specialities that have to tell you if their product works on an Uhlenbrock booster. And w/o having a look at the diagram of the circuit breaker, I doubt it'll work: Uhlenbrock uses the Märklin way of generating a DCC signal, where one terminal of the power supply is hard wired directly to one of the rails. So I'd suggest to contact DCC Specialities on that subject, because I suspect they're assuming the Lenz/Digitrax way, with a full H-bridge output stage.

That's interesting. I tried using PSX 1's with my Gaugemaster/MRC PA2 system and all it did was duff up the command station which then needing repairing. DCC Specialities felt they should work. Not all CB's are thus the same, or compatible with all DCC systems. Very awkward unless you know.

 

Izzy

Share this post


Link to post
Share on other sites

Looks like a similar problem to the one I had with decoder compatibility with the MTS system, finding someone who's tried it out! Thanks Izzy and DM at least I know to keep looking on that bit.

Share this post


Link to post
Share on other sites

I doubt whether you will have any problem using the PSX1 with an Uhlenbrock booster.  I have been using for years an Uhlenbrock Intellibox and Intellibox 2 with a Digitrax PM42 cut out, so there is no inherent incompatibililtly with other manufacturers' overload devices.  The PSX admittedly works in a different way.  I bought one recently for the next stage of my layout, though I have not installed it yet.  I have done a quick test;  the PSX works perfectly when a  short circuit is induced and the Intelliboxes are unperturbed.  So I cannot offer you a report on long term use, but the indications are good.

 

I think it unlikely that you will get a definitive answer from either DCC Specialities or DCC Supplies.  Uhlenbrock withdrew from the American market years ago, so DCC Specialities have probably never tried a PSX with an Uhlenbrock booster.  DCC Supplies, though very competent people, do not deal in Uhlenbrock, so may be in the same position.  You could consider phoning A&H Models, the UK Uhlenbrock importers; there is a sensible and knowledgeable man there called Chris who is probably the No. 1 Uhlenbrock expert in the UK.

Share this post


Link to post
Share on other sites

Thanks, I've emailled James at DCC automation as he supplied the Z21 and booster and lists dcc specialities so hopefully can shed more light on this before spending a hundred quid.

Share this post


Link to post
Share on other sites

Hi I have had myZ21 for 10 months now and been very pleased with it, however over the past month I have had problems with a message coming up that Z21 has stopped working  I can download the layouts but when going to run a loco this is when the message comes up ,I am using an Android app and on a Samsung Galaxy Tablet 3 and a Samsung galaxy 3 mobile, the strange thing is that I do not get any problems using the mobile. Is the App on the tablet the problem ? I was thinking of uninstalling the App and installing the App again, the problem with this however I would have to start all over again in listing all my loco layouts settings as I have listed 10 layouts on the App .I would much  appreciate any suggestions, I have e mailed Roco and sent a report to Google but await any answers as yet,

Share this post


Link to post
Share on other sites

Try DM's idea or if you can load layouts you should be able to transfer them to the phone via the Z21 then purge it as above then transfer them back. You can transfer android to android and IPhone to iPhone, but not iPhone to android or vice versa.

Share this post


Link to post
Share on other sites

Thanks Dutch Master and Paul Rhb, for your replies, but as not being entirely computer language savvy what does purge app mean? Also what does power cycle mean? Sorry if I sound stupid.

 

John

Share this post


Link to post
Share on other sites

Honestly John you don't it's a learning curve for all of us :)

Purge meaning delete the app, then, Power cycle meaning shut down and restart the tablet so it clears it's little electronic brain and then reinstall the app.

It's not uncommon for some little gremlin to be cleared this way as it makes sure everyhing starts in correct sequence ;)

One of my iPhones I use as a throttle locks up occasionally as it's near capacity and old and reseting it sorts it out.

Edited by PaulRhB

Share this post


Link to post
Share on other sites

Another twist to this android tale, I had only tried the layout I am using at present a steam German and it was one I had to relist as it had disappeared from my railroad layout, as my mobile worked I decided to try another layout on the tablet and I was surprised to see that it worked as normal , tried another that worked etc, but the original just won't so before doing anything else I shall delete the offending layout not too many locos on it and start again with it. However I shall save the valuable advice given by PaulRhB and Dutch Master, thanks again gents for your swift assistance.

Share this post


Link to post
Share on other sites

It's also worth reporting any repetitive faults via the Z21 website, the response isn't fast but they do listen and add stuff in the updates to fix bugs if they can replicate it.

Edited by PaulRhB

Share this post


Link to post
Share on other sites

Regarding my problems with the non working railroad, I found out another anomaly in this layout, I had set up  a double header of two KPEV tank locos,{although at first the locos did run]  after I had deleted the double header, the German layout was available again! Whether I had set this up wrong or it was one of "those things". I do not know.

On the reporting issues I  have not heard from Google , I have found in the past Roco reply with an order number immediately, but take a little time in replying until they have understood the query, so if I get an answer from either or both I will post it on this thread.

Share this post


Link to post
Share on other sites

I have just received this fast and responsive communication from Roco,

" The Android App can be slow or sometimes have an app -stop, if the locomotive  collection exceeds more than 50 locos. We are engaged to patch this bug with the next app update and ask for patience in this context. Thank you for your understanding in advance"

So a promising outcome to the problem I may encountered. Whether they mean a total of 50 locos or 50 per layout it is not clear but as I have 17 layouts made up and most have an average of 22 locos per layout, [ I take it to mean per layout ,so a little ambiguous meaning perhaps], these layouts do have duplications. I do have a 3 figure number of locos built up over the years but not 374!

Edited by brittannia
  • Like 1

Share this post


Link to post
Share on other sites

Are Roco still developing the Z21?

 

It seems to have no updates or news in a very long time, unless i am reading in the wrong places.

Share this post


Link to post
Share on other sites

I have just received this fast and responsive communication from Roco,

" The Android App can be slow or sometimes have an app -stop, if the locomotive  collection exceeds more than 50 locos. We are engaged to patch this bug with the next app update and ask for patience in this context. Thank you for your understanding in advance"

So a promising outcome to the problem I may encountered. Whether they mean a total of 50 locos or 50 per layout it is not clear but as I have 17 layouts made up and most have an average of 22 locos per layout, [ I take it to mean per layout ,so a little ambiguous meaning perhaps], these layouts do have duplications. I do have a 3 figure number of locos built up over the years but not 374!

 

 

I had the same problem of the system closing down on me after I had loaded a largish number of locos on the locomotive settings page. Contacted Gaugemaster who said that they had not heard of the problem and contacted Roco but got no response.

 

As it happens I was off to Germany earlier this year to attend (amongst other places) the InterModellbau in Dortmund where Roco had a Z21 Stand. I cornered the Z21 Specialist and with the help of his younger assistant tried to explain the problem being encountered. At first all I got is that the blurb that the system can take 9900 (or whatever) addresses but finally my message got through and it was suggested that to stop the system shutting down I should go through my locomotive settings and only mark as "Active" the locos that I was only using on that session. This I did and the problem of the app shutting down disappeared.

 

A couple of months ago I finally got an e:mail from Roco referring to my original e:mail (sent more than 6 months earlier) saying that a system update will be made soon to solve the problem.....

 

My worry now is how to do a system update without losing all the data stored on my Android phone. Its great people telling you to export the data somewhere, download the update and then import the data back onto the phone but not having done anything like that before I would like to see some written documentation telling me (who is certainly not a technical whizzkid) exactly what to do.

 

It would also be nice to get some e:mail updates on what enhancements to the system are made. I thought I registered for this when I first bought the system but no such information has been forthcoming.

 

Keith

Share this post


Link to post
Share on other sites

The best source of info in English on the updates is the A&H site linked to earlier in the thread.

Does android have a backup to the PC option like the iPhone? I've never tried on my tablet as it was set up via wifi.

If you need a written guide on transferring between handsets to give a backup I can do a step by step on the iPhone as the procedure should be identical to Android but you'll need a second android device. I'd offer my direct help but it's a bit far to pop round Keith.

Share this post


Link to post
Share on other sites

Gaugemaster also have on line a written explanation of some of the different tasks that can be performed on the Z21 ..So matching A&H and Gaugemaster can give a great help in understanding the workings of the Z21.

Share this post


Link to post
Share on other sites
Guest

Brittania,

 

I have searched the gauge master site and I could only find the Z21 brochure.

 

Could you please post a link to the gauge master pages you mention in your post

 

Cheers

Share this post


Link to post
Share on other sites

Ssamm

 

It was in the fortnightly e mail RightLine e mag from Gaugemaster, I have e mailed them to ask whether they could reproduce it on the website, I will give Gaugemaster  a call tomorrow and ask them that question again, one of the chaps in the shop has wrote the article and as far as I know it is a series of hints.

I did presume it would be on online site as well

 Brittannia

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.