Jump to content
 

certain revell paints spraying funny


Recommended Posts

hello i have been using the following three paints all revell enamel:

matt 2 (clear)

66

91 (both two types of silver)

 

i have never had any problems spraying enamels before sometimes even without thinners in them i have never had a problem but when i try to spray those three the paint is always blotchy and sprays weird, is there something i have to do with them or are they not for spraying, they have all been shook for 30 seconds and ive tried all of them with and without thinners but haven't solved the problem.

 

could anyone shed some light on this, i need to use all three colours and cant because of how they spray!

 

thanks for reading and i hope you can help!

 

Thanks

 

- Dan

Link to post
Share on other sites

I have some Revell enamels that even though I stir them for at least 5 minutes they string like UHU glue. I apply by brush but maybe your painst are exhibiting the same thing resulting in the blotchy finish you are getting.

Link to post
Share on other sites

There was I thinking that it was just me who had problems with Revell paint*. It tends to be very variable, I find, and I usually avoid it like the plague, though I have to admit the last one I used was OK. (I couldn't resist four tins for 50p at a boot sale.)

 

I would agree on the necessity to stir well.

 

* I find it tends to be too thick as it comes and once thinned sufficiently it no longer covers.

Link to post
Share on other sites

Hello all,

 

when I used to do a bit of spraying I used to add a ball bearing (about 3/16", 5mm dia) to the tin and shake it until I could hear the ball rattling about, then carry on shaking it (is that a film?) for another two or three minutes. After that give it a good stir, after that thin for spraying and another good stir.

 

OzzyO.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...