Jump to content

QSI Sound DCC running issues


Recommended Posts

Guys. I know this should probably start in the DCC area but theres a lot of other UK stuff there and I guess those that know might be looking in here. I have some very specific DCC issues with Broadway QSI equipped locos and LENZ 100 DCC system. They all run like dogs! USed to be fine but now they all don't respond to throttle for ages then surge forwards and then stop, then surge again without any further throttle inputs? Anyone seen anything like this. Hoped it was one loco but it is all of the Broadway ones and some older Atlas ones too? Other locos with Tsunami, Bachmann. Lok decoders are absolutely fine. Help!!

Link to post
Share on other sites

 I can only suggest that you do a factory reset and hopefully that will expunge the problems.  If you know someone with a QSI programmer, that may help.  I have a couple of first-run Atlas QSI-equipped Trainmasters (both with an upgraded chip, following the originals not having BEMF); both were dogs to set up, and at least one is now behaving a mite erratically.  If I had the money, I'd replace the decoders with Loksound Selects.


And my DCC system is Lenz, by the way.



Link to post
Share on other sites

That is very strange behaviour indeed. I can't say I've experienced the same. I've got one QSI equiped locomotive, but I have had no issues with it yet. (also on a Lenz system).

They can be very complex to program indeed, so if you have access or facilities to program using a computer running Decoder Pro, then that would make it all a lot easier.

It would also give you the option to first 'import' all settings of the loco as current, so that if you do a factory reset, and you can't figure it all out, you can at least load up the settings as they were, and give it a second try later.

(if you already have a backup of the locomotive then try to reload it). 

It would be interesting to know what happened that made them change in behaviour, did you change DCC systems? Only curious as you describe that they 'used to be fine'.


Recently at our monthly modular meet, we had a couple of Broadway locomotives, and we use an Lenz. system there, they behaved absolutely fine, so I can only imagine some strange 'spike' has occured, caused by a disturbance or short circuit to which your QSI equipped loco's were sensitive.





Link to post
Share on other sites

sounds like you have 2x issues here


1-Lenz system stack memory is full.


do a factory reset on system?


with Address 0# on handset

press button 4# 25 times, turn power off wait 10 seconds turn power back on.


2-Packet timeout on each QSI decoder


you also may need to alter cv11 with qsi decoders, try altering it to a value of either 0 or 20.

packet timeout - page 38








Link to post
Share on other sites

  • 2 years later...

Thank you very much for the above. I bought two second hand Atlas sound locos from Derby exhibition on Saturday. When I finally got them going after doing resets with the magnetic wand they ran as described in post 1. I tried everything I could think of. Changing CV11 to 0 solved the problem. Thank you Neil Rogers. CV11 is not listed in any of the literature supplied with the locos, nor could I find a list on line. Thanks again. Where would we be without rmweb and its members? All the best, Trevor

Link to post
Share on other sites

I have also had issues with an Atlas QSI B23-7, it never works properly after not being used regularly. Biggest issue for me is the poor sound, things have moved on in that area so no amount of tweaking of CV's is going to improve that.

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...