Jump to content

Sign in to follow this  
melmerby

Setting a non standard display with a Raspberry Pi

Recommended Posts

Hi all

As part of another project I am setting up a Raspberry Pi 3 B+

I have a dedicated LCD display made for a Pi with the resolution of 1024x600

The manufacturer lists some changes to be made to the config.txt file:

 

max_usb_current=1

hdmi_group=2

hdmi_mode=87

hdmi_cvt 1024 600 60 6 0 0 0

hdmi_drive=1

 

These seem to agree with what can be found on the Pi forums

However the display just shows a load of coloured lines

I have tried several different resolutions including some standard ones from the list (e.g. 800x600) without success.

The display is fine, if I plug it into Windows it is instantly recognized as a 1024x600 @ 60Hz device and a proper display is obtained.

 

The Pi works fine on 1920x1080 as I am posting this from it!

 

Any suggestions to what might be wrong?

 

Share this post


Link to post
Share on other sites
 

Have you tried it using the standard config file? If so, what happens?

 

Normally, Raspbian should automatically pick up the display settings just like Windows does. I first started using a Pi 1 with a 1600 x 900 monitor which it picked up straight away. Later changed to a 1920 x 1080 monitor and it picked up the change straight away—no config file changes made.

Share this post


Link to post
Share on other sites
2 hours ago, D9020 Nimbus said:

Have you tried it using the standard config file? If so, what happens?

 

Normally, Raspbian should automatically pick up the display settings just like Windows does. I first started using a Pi 1 with a 1600 x 900 monitor which it picked up straight away. Later changed to a 1920 x 1080 monitor and it picked up the change straight away—no config file changes made.

Reading the info on the Help pages suggests the Pi defaults to 1920x1080 unless you tell it otherwise

This is what I get with default settings:

waveshare.jpg.d8e8898ef5b64b8e388b26ea53165272.jpg

If I change the config.txt file as recommended,  it makes no difference, it looks the same.

 

The display correctly identifies itself to Windows as a 1024x600x60 display and Windows fills the screen exactly

Th Pi displays correctly on a 1920x1080x75 display.

Share this post


Link to post
Share on other sites

Fixed

I found that you cannot change modes if you have used Noobs to build the image.

Apparently although Noobs makes the boot up files, it doesn't use them, so altering config.txt is a waste of time, it does nothing.

If you use Raspian Buster to make the image it works fine.

 

Now up and running 1024x600 and posting this reply.

 

EDIT, even the touch screen is working and I didn't have to set anything up.

Edited by melmerby

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.