Jump to content

Peco code 75 asymmetrical electrofrog point dead zone issue


Recommended Posts

Hey guys I’m pulling my hair out over an issue I have with the above point. 


Turning left or right out of the turnout works fine. Going straight through however any loco dies on the blades. 


I’ve done the standard point alterations whereby the three rails either side before the first frog are bonded together using the dropper wire. 


Ice tried an 0-6-0 pannier tank across it and a class 3mt and both stall in the same place. 


The turnout is powered from dcc track bus  feed and the turnout blades are fired using two tortoise point motors. 


I have the two frog dropper wires going to the frogs on the right side of the track feeding into the same point motor with the other frog on the left going to the second motor. 


There are no shorts occurring as the cab would moan at me if there were (and the lights would dim). The locos just stall. 


I’m using an NCE Power cab for control and power. 


Any thoughts and ideas are greatly welcomed as I’m pulling out my hair trying to figure out what could be wrong!

Edited by MrDobilina
Typo fixes
Link to post
Share on other sites

Just had the same issue and solved it by bonding the fixed rail between the frog and the blade to the outer running rail. The problem is that the point blade fails to contact the stock rail properly.

In my case I was using very short locos and when the loco was on the moving blade all was fine, as soon as it moved between the moving blade and the frog it stalled. No power was getting to that rail. I simply ran a wire from the running rail to that rail, soldered it up and everything is fine.

As in my case all was fixed down and ballasted it was a fiddly exercise, but it works.


I'm out with the layout at the Risex show on Saturday so it was an urgent job!


Poor blade contact can sometimes be an issue with Code 75 points

Link to post
Share on other sites

These points are usually fine straight out of the box on DC so maybe you cut and re connected the wrong wires.   Multimeter will indicate which rails are connected to which others so is pretty much essential to get one before cutting wires on your points    It could be  the point blades are not making contact at either the pivot end or the rail end. when the weight of the loco is on them.    A multimeter won't show this up if it only happens when the weight is on it.

I really don't understand why people fiddle with elctrofrog points on DC. They can't take the load of a six loco lash up with lights and sound on DCC so need additional wires and switches if you run 100 car freights with 6 locos on DCC but not indoors on DC with at most two locos.

I sometimes use a test loco. It had pick ups on only one wheel each side and if it stalls anywhere I sort the problem, a one axle pick up wagon with a light is another useful tool, light stays on on every route then its sorted. If it aint fetch the multimeter. Saves a lot of messing about.


  • Agree 1
Link to post
Share on other sites

On 25/02/2019 at 00:36, DavidCBroad said:

I really don't understand why people fiddle with elctrofrog points on DC.


Have to point out I did state in the original post that I was using NCS power cab, thought that was 'standard' for DCC. But to be clear, I am not using DC I am on DCC.


I have however figured out the issue. The point was fine and the modifications were fine except one rail which the solder contact was a bit poorly done on my behalf. I've resoldered that rail and voila it works perfectly again even at extremely slow speeds.


Thank you all for your help and comments!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...