Jump to content

LittleRedTrain

Members
  • Content Count

    13
  • Joined

  • Last visited

Everything posted by LittleRedTrain

  1. So my Baldwin arrived back from Bachmann today. They couldn't find a problem with it on DC or DCC, but reset the decoder anyway. Their recommendation was to ensure that I supplied enough power on starting to prevent stalling (which should be a non-issue with a light loco on level track). Upon trying it, it still seems to exhibit occasional cut outs at slow speed. I'm wondering whether there's either some mechanical or electrical issue that is manifesting on my layout but not on theirs for some reason. It's almost like it hits a dead spot, as a tiny nudge is enough to get it going
  2. NSE 4-TCs with water damaged boxes for £189.99 at Kernow http://www.kernowmodelrailcentre.com/p/68531/32-643Z-Bachmann-Class-438-4-TC-Unit-number-8023-SOILED-BOX
  3. For anyone who got Amazon vouchers for Christmas: Hornby R3854 LMS, Princess Royal Class, 4-6-2, 6212 Duchess of Kent for £146.67 https://smile.amazon.co.uk/dp/B08485GFGG/ref=cm_sw_em_r_mt_dp_lG25FbDWDKT5E Free delivery with Prime, sold by Amazon itself. Cheapest I've seen it, though usual caveats about Amazon apply (price can change at any moment, especially if others look at/buy it). EDIT: Has now changed to £147.20 EDIT Sun 27: Has now gone back to full price I'm afraid.
  4. I've finally got enough track on my 009 layout to test my WHR 590 (Red with DCC sound) which was part of the second batch and purchased almost exactly a year ago. Unfortunately it seems to exhibit a very similar problem. Does anyone know if the same diode issue affects these second-batch/DCC fitted locos? My GVT Baldwin (fitted with the same decoder bought SH from someone who didn't want a sound-fitted version) runs fine. I've only run it with a Gaugemaster Model D on analogue and a Prodigy Advance 2 on DCC, so an old/feedback controller isn't the issue.
  5. My red one still hasn't arrived. Rails have kindly sent me the tracking number and apparently it's still at 'PSC South Yorkshire' as of yesterday. Hopefully it may make its way down to the Midlands sometime this week! EDIT: Finally arrived Wednesday 16th morning
  6. Not sure if it's a bargain per-se, but Clark Railworks have an 'as new' Brighton Belle train pack, with 3 trailer coaches, for £275. My understanding is that these were quite hard to get hold of. https://clarkrailworks.com/collections/new-arrivals/products/Hornby-oo-r2987-brighton-belle-1934-train-pack-w-r4512-13-14-brighton-belle-cars They also have a number of other Hornby train packs with additional coach sets for what seem like pretty reasonable prices. https://clarkrailworks.com/collections/new-arrivals No connection other than as a previous satisfied customer.
  7. Pre-ordered two from Rails (separate orders as originally the sound and non-sound versions were due at different times). - Red one without sound was dispatched on Tues and still hasn't shown up. - Black one with sound was dispatched on Weds and arrived on Thursday. Go figure! Hoping the red one appears in tomorrow's post.
  8. LMS 8F for £89.99 also seems a pretty good deal. Don't think I've seen this under £100 before. http://www.kernowmodelrailcentre.com/p/56202/R3565-Hornby-8F-Class-Steam-Locomotive-number-8035-LMS-Black
  9. OOS now, but MRD have one at £132 https://www.modelrailwaysdirect.co.uk/train-packs/Hornby-r3397-lms-suburban-passenger-train-pack-limited-edition/ I'd have had it myself if I hadn't just bought 4 of these coaches in the latest 'Rails' deal. EDIT at 17:45: Now gone!
  10. Surprised and a bit disappointed that the Baldwins have been pushed back to April. They were shown as expected this month until very recently!
  11. Ordered a green Lyd from Bure Valley Models (who incidentally have it at £178, cheapest I've seen). Unfortunately after a quick test run, the valve gear came apart on both sides (drop link came astray and one of the tiny pins shot off never to be found), so back it had to go. Full marks to BVM, I phoned them on Friday to arrange the return, posted it on Monday, and the replacement (which they had test-run for me) arrived Thursday morning! I've now had a chance to run it on my oval test track, and after applying the recommended fixes of loosening the pony centering springs
  12. Hi all, I wasn't quite sure which section to put this in, so please feel free to move if incorrect. I was trying to fit a DCC decoder to my Hornby 4-VEP and, in a rather ham-fisted fashion, managed to accidentally pull out one of the cables that links the roof-mounted PCB to the socket on the chossis. Having neither the eyesight, skills or patience to try and re-solder the tiny connections, I have bought a replacement PCB, however, I can't figure out how to get the old one out to swap it without having to perform serious surgery. The PCB is held into th
  13. Hi all, Apologies for re-awakening a slightly old thread, but I've been trying to chip my class 122 and having similar, but slightly different issues to those mentioned above. I'm using a Zimo MX638D, (non sound, and the documentation shows Function 3 as a non-logic level), with a Gaugemaster Prodigy Advance2. However, rather than the interior carriage lighting remaining on constantly (as others have said), it remains off and none of the function keys appear to turn it on. The interior lighting works fine on DC with the blanking plate inserted, so it's not a problem wit
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.