Jump to content

Recommended Posts

Done. Laptop 192.168.1.102, TP-link 192.168.1.1, 192.168.0.1 - Arris (modem), 192.168.1.100 - unknown (webpage n/a) and 192.168.0.3 - unknown (webpage n/a).

z21 is supposed to have factory default setting 192.168.0.111 but  it doesn't respond to that address.

Share this post


Link to post
Share on other sites
 

Assuming fixed address in z21, you need to reconfigure the router to use the range 192.168.0.x. I'd so this with the laptop set to DHCP, as the address in the laptop needs to reset as the router resets.

 

( this is heading to moderately complex networking, so tread carefully if not sure about things )

Share this post


Link to post
Share on other sites

Sounds a bit scary to me, not sure I can do it on my own. Maybe I just wait till Sunday and try to exchange the z21.

Thank you all for trying to help and Happy New Year! 

Share this post


Link to post
Share on other sites

The problem isn't in the z21 - at least not from what has been said so far - its in the router configuration.   So, if swapping things, on the evidence so far, its the router which needs swapping. 

 

The router appears to be set for range 192.168.1.0 to 192.168.1.255.   But, according to the documentation and Dutch_Master, the z21 is factory configured for 192.168.0.111,  so the router needs to be configured for that address range (192.168.0.0 to 192.168.0.255).

 

As the z21 has a static address, the only way to communicate with it is by using a router with the appropriate address range.    

Your laptop and tablet will almost certainly be using DHCP, so they get an address allocated by the router they connect with (and that address will change with each different router they connect with),  so those devices should sort themselves out - the reason for using cable from laptop to router for configuration work is that it reduces problems to one place (network addresses) rather than several (network addresses, WiFi network names, WiFi security settings,  etc.. etc... ).

 

 

- Nigel

Share this post


Link to post
Share on other sites

Hi VRR,

 

Hopefully I can help you sort out your problem, and save you a 4 hour round trip!  Also if my hunch is correct then miraculously everything will work when you visit your dealer and then break again when you get back home (if you plug everything back in as shown by your pictures).

 

Sorry if I'm telling you to suck eggs or you have tried what I suggest already, but I know how frustrating computer networks can be and I do internet/web/network stuff for a living!

 

Nightlife and Dutch_Master have provided all the answers and your pictures point to the problem, so hopefully this will help join the dots.

 

If you want the simple solution, just follow the list in order (only completing it will make everything work), the reasons are listed as well if you are intersted but if it's all seems like a foreign language then ignore!

 

The simple route of your problems: your home Belkin router.

 

1) unplug the grey network cable connected to the TP Link router WAN port (I'm guessing you've plugged the other end of the grey network cable to your Belkin home router)

 

Reason: By plugging in your own home Belkin router to the WAN port of the TP Link router you are in a whole world of hurt. The TP Link knows that the network it sees on the  WAN port needs to be isolated from the network that it will be providing, it does this by using a different subnet. A subnet is a different range of IP addresses (also called network addresses), defined by a mask (called the subnet mask) which is usually 255.255.255.0 for small home networks and routers, so it means that IP addresses that have the same first three sets of numbers are in the same subnet. Because you have plugged your home Belkin router into the WAN port of the TP Link and because the 192.168.0.x subnet is the most commonly used subnet for home networks it sees that the Belkin (plugged into the WAN port) is using the 192.168.0.x subnet already. So to play nicely the TP Link automatically uses the next available subnet of 192.168.1.x. Now because of this, only addresses in the subnet 192.168.1.x are able to be used by the TP Link and because the z21 has a fixed IP address of 192.168.0.111 it is not able to be seen by any network because it's IP address does not match the subnet mask. So I repeat, unplug the grey cable from the TP Link, in so doing disconnecting it from the Belkin router.

 

2) (optional) reset the TP Link router.

 

Reason:You may want to skip this step because it is possibly not needed (and could wipe the settings programmed by Roco), but: if the TP Link has stored the fact that is has previously used the 192.168.1.x subnet it may continue to do so, this would prevent it 'seeing' the z21, even through you have disconnected the TP Link from the Belkin router.

 

3) cycle the power to both the z21 and TP Link.

 

Reason: Just to make sure, switch it off and on again ;-) Hopefully when everything comes back on the TP Link should be using the 192.168.0.x subnet by default and be able to 'see' the z21.

 

4) connect your Samsung tablet to the wireless network provided by the TP Link router - NOT your normal home wireless network.

 

I think the name of the TP Link wireless network suffix and the password are listed on the bottom of the TP Link router (not sure - don't have one!). I think the network name should start with (Z21_ or z21_) and be followed by 4 digits (the last 4 digits of the serial number of the TP Link Router. Or alternatively you could just look for the wireless network that appears when you turn on the TP Link router - this may be needed if resetting the router also reset the TP Link's wireless network name. The password for the wireless network is listed as the PIN on the bottom of the router.

 

Reason: The z21 is only connected to the network provided by the TP Link router - your tablet needs to join the same network as the z21.

 

-----

 

OK hopefully things should now work.

 

If it still doesn't work:

 

Find out the following things as they will help troubleshooting:

 

a) what is the IP address of your tablet when you connect to the TP Link wireless network?

b ) can you check the IP address of the TP Link router - what is it?

 

You can always plug a laptop into the other network LAN ports on the TP Link router if you want to use software to find out the above, but you should be able to see the addresses on the wireless setting page on the Samsung tablet.

 

Let me have the answers - and we'll fix things together from there.

 

If it does work but you have questions:

 

​a) how do I connect to the internet and the z21?

 

Simple answer - you don't. You connect to your home wireless network for the internet or the TP Link network for the z21. To make things simple that is why Roco gave you a separate router. The TP Link is totally unnecessary if you know what you are doing with your own router, but if not then the simple solution is to use a completely different one.

 

b ) no, but what if I really want to connect to the z21 and my home network - how do I do that?

 

The Roco manual is a little too simplistic in some areas and doesn't make sense in others - so I can understand the confusion. They even say you can plug into the WAN port OK, but then their router configuration manual (in German) says not to use the WAN port at all!!

 

First - throw the TP Link router in the bin - you don't need it. 

 

Next a quick bit on IP Addresses: there are a limited number of IP address in the world, and indeed in the world of your home network of only one subnet you only have 255 addresses available. You router uses one of these so you only have 254 left. Because you will want an easy life, and because it's never good to run out of IP addresses, routers come configured to dynamically allocate IP addresses to devices by default. This means the router acts as a DHCP server. So every time a device connects to the home network it gets given a dynamically assigned IP address. But here is the problem: every time you reconnect you may get a different address - even if you use the same device. For 99.9999% of the time this is not a problem as everything will still work, even if your IP address continually changes.

 

However - Roco decided it would be too hard to have the IP address of the z21 changing all the time - how would their tablet software know how to talk to the z21? So they took the easy option and gave the z21 a fixed IP address. This is 192.168.0.111 by default (it would seem). A fixed IP address may cause havoc with a router using DHCP that has more devices connected (like your home router) so hence why they took the simple route and gave you the TP Link router.

 

If you want to use your z21 on your home network you need to check several things - then (according to the theory) everything should work just fine.

 

a) plug your z21 into a spare LAN port on your router.

b ) make sure your home network router uses the 192.168.0.x subnet as default.

c) find out the MAC address of the z21 - you'll need some network sniffing software for this - or it could be written on the bottom of the z21 (I don't have one to check).

The MAC address is in the form of 6 hex octets (some thing like 6f:a4:76:0c:e4:bd) it is a unique physical address for the network port on the z21, because there are so may combinations of MAC addresses I really mean unique. Every device/port in the universe has a different MAC address - no single one is shared. So your z21 will have a different MAC address than someone else.

d) You need to reserve the IP address 192.168.0.111 in the DHCP server settings of your router - you need the MAC address for this. You are basically saying 'reserve the IP address of 192.168.0.111 for the device that has the MAC address of {your z21 MAC address here...}'. Every router is different - but I hope you get the idea.

e) Now your z21 should live happily amongst all your other network devices, and when you connect to your home wifi network your tablets should be able to see the z21. Don't worry about any network overloading or conflicts or that you are going to slow down your home network - that'll never happen.

 

And here endeth the lesson ;-)

 

Hope that is useful to people and more importantly it sorts out VRR's problem and that the enjoyment can begin.

 

Cheers,

Matt

Edited by Matt Roe

Share this post


Link to post
Share on other sites

Matt, thanks for your reply.

 

1. The grey cable is plugged into the modem, not Belkin.

2. I'm not afraid to reset the router because I've already done that (and wiped Roco settings). Now the router's network name is "TP-link" (not "z21") and no password is needed.

3. My Samsung is connected only to TP-link.

4. I don't really need to connect my Samsung to the Internet.

5. Router's IP address of the TP-link is 192.168.1.1, The modem's address is 192.168.0.1 and the laptop's - 192.168.1.102

6. I don't know how to figure out the Samsung's IP address.

7. The bottom of the z21 box only lists the IP address 192.168.0.111 not the MAC address. I have no idea how to figure that out.

Share this post


Link to post
Share on other sites

Unplug from modem, then restart everything and try again.

 

Matt has described what is (most likely to be) happening. The modem sets its address, and the TP-Link router takes the next address range.

Share this post


Link to post
Share on other sites

WOW! Great Almighty! I fixed the problem!

The problem, as I understood, was in the Time Warner Cable (my ISP) modem. It has the address 192.168.0.1 hence the default Gateway for TP-link is 192.168.0.1

The WAN and LAN can not be in the same subnet - therefore LAN took 192.168.1.100 to 192.168.1.199 address pool. And it can not see my z21. And it can't be changed by me.

What I did? I unplugged TP-link from the modem, from my laptop, and reset it. Then connected my Samsung tablet to TP-link network and then connected z21 to TP-link by cable.

Hur-rah!

Thank you all for teaching me some basics here!

Share this post


Link to post
Share on other sites

Oops! Nigelcliffe already suggested that and didn't see. OK not "I fixed the problem" - we all together did...

Share this post


Link to post
Share on other sites

Lesson learned, and maybe an advice to fellow z21 new users:

 

1. The installation disc that comes with z21 sets - you could use it as part of your scenery, and if you have tunnels on your layout (I have a lot - I'm trying to build a Russian style Metro) shove it up the longest tunnel but DON'T USE IT to set up TP-link router.

2. DON'T CONNECT TP-link to your desktop or laptop computer/

3. DON'T CONNECT Tp-link to the Internet.

 

Use the router as is (the Network name will be "Z21_wxyz with "wxyz" being the last 4 digits of the serial number on the bottom of your router and the PIN also from the bottom of the router)

OR RESET the router with a needle (the network then will be "TP-link_wxyz" and no password protection).

 

I wonder do ROCO guys think we have to become TCP/IP experts in three sleepless nights like in my case?

 

Thanks again for all your help!

Share this post


Link to post
Share on other sites

I did  say I had the problem of the tablet still trying to be being connected to the internet router, but because my layout is out of range of my internet setting it was just a matter of re-setting to the Roco address, but I am not qualified to know how or what really was the problem!

Share this post


Link to post
Share on other sites

Hi,

 

I have just ordered a Z21 and cannot wait for it to arrive. I was hoping someone who already uses the system maybe able to answer a question I have not been able on the web? Can you use more then one ipad/iPhone at the same time so two seperate people can control different locos?

Share this post


Link to post
Share on other sites

VRR, glad you got it sorted, as Dutch_Master and Nigelcliffe had pointed out connecting something to the WAN port of the TP Link router was the reason for all the problems, hence why it was number 1 on my list.

 

Have run with DCC, as for me I'm happy with my couple of Multimaus ;-)

 

Matt

Share this post


Link to post
Share on other sites

Yes, up to 10 mobile devices can connect to the Z21.

Thanks 'DM' cannot wait for it to arrive now! :)

Share this post


Link to post
Share on other sites

All, quick question if I may? My wife bought me one of these for Christmas. It all seems so simple, but unfortunately it keeps flashing red on the front, which I understand means a short. It does this even when there is no track connected. Does that mean it's faulty, or am I just doing something really basic wrong? Cheers

Share this post


Link to post
Share on other sites

Sounds like a fault if there's nothing connected. Might be a loose wire somewhere. Just check there's not a single strand caught in a connector and if not contact the shop.

Share this post


Link to post
Share on other sites

From their FAQ page

 

"hold until LED blinks red (ca. 3s): restart "

 

Is the button stuck in?

Share this post


Link to post
Share on other sites

From their FAQ page

"hold until LED blinks red (ca. 3s): restart "

Is the button stuck in?

Thanks for the advice. When I push the button, the light goes blue momentarily, then straight back to flashing red. There is nothing (absolutely nothing) connected! I've tried pressing for 5 seconds to reset to factory settings (light goes purple), but again, straight back to flashing red.

 

Will let you know how I get on with the shop concerned!

Share this post


Link to post
Share on other sites

Hi, thanks to Dutch Master I have my system working, but I have one or two problems, 1) All my locos ran the same way with the gaugemaster unit but I have only three out of 10 sofar entered into the system that run the right way, is it possible to change the direction without having to change the CV's? 2) I have used the camera on the phone to take pictures of the locos but 2 are not right and I can't find any way of editing them and replacing the image. 3) two loco's do not respond to the original programmed number, do I need to re-programme them.

 

I have not yet tried the program facility of the Z21 as my programming track is connected to another system in use on my N layout, its made for use with O, OO & N.

 

Hope I am not just being thick! but it's the first time I have ever used a mobile phone so have two learning curves at once.

 

regards

 

mike g

Share this post


Link to post
Share on other sites

1) All my locos ran the same way with the gaugemaster unit but I have only three out of 10 sofar entered into the system that run the right way, is it possible to change the direction without having to change the CV's?

 

2) I have used the camera on the phone to take pictures of the locos but 2 are not right and I can't find any way of editing them and replacing the image.

 

3) two loco's do not respond to the original programmed number, do I need to re-programme them.

 

 

Ok

1

On the Z21 the arrow pointing to the right is default forward so any steam loco with smokebox as forward should point to the right in your picture.

It could be you've got the chip wired in reverse to the motor or change cv29 by adding 1 to the value already in there.

 

2

Take a photo with room around the loco so you can crop it.

Go to settings - railed vehicles - tap appropriate loco - scroll down and tap on the current photo.

Choose from Photo library.

Now just use two fingers to resize the image so it fits the 'bright rectangle' in the centre.

Then click Use.

 

3

You might but have you added 0's in front?

Z21 doesn't need them for, say loco 12, just put 12 NOT 0012

 

See how you get on with that and hopefully it'll sort it ;)

Share this post


Link to post
Share on other sites

Paul, thanks for the reply. All my loco both steam and diesel went the correct way with the gauge master as I wired them to go the way they should. I thought that you had to deduct 1 in CV29 to change the direction, as most of my locos have values in the upper 30's so as to work on DC as well as DCC for club use.

 

I do not have a picture library, but I tried to edit as you suggest but got no response from the phone. The phone does not appear to save the photos just puts them straight into the loco library! I may be doing something wrong as it's the first time I have used a mobile, it's not got a sim card installed would that be causing a problem with the pictures, I know the sim is not required to use the Z21.

 

I have no leading 0's that I am aware of but I did have a loco with a Zimo chip that decided that it wanted to be 0000 and I could not read it I sent it back and had it reset to the correct No, I have no idea as to how it got changed, it had been working for several days before it stopped responding!

 

regards

 

mike g 

Share this post


Link to post
Share on other sites

No you don't need a Sim as three out of 4 devices I use don't.

 

In cv29 (bit 1) it's usually values of

0 normal direction

1 reversed direction.

Check your decoders manual for cv29

 

Re the picture library this seems strange, does it look like this video when you do it? (Take pics first so they save to your library then go into the Z21 app)

 

Edited by PaulRhB

Share this post


Link to post
Share on other sites

Paul, thanks for the reply. All my CV29 settings are as the decoder manuals and as I have several parts switched on are nearly all between 35 & 37 depending on direction, I have been checking today with the programming track and I found that the locos that were not responding had reset to 3, a quick reprogram and they are now all working, all so I upgraded the Z21 as I had not the controls shown in the pictures I found last night of the screens on the roco site, now seem OK. I have also found that when I put a new loco on the track with one running the system seems to auto reset to 3.

 

The pictures do not work as per your video but I have found that I can delete the ones in loco list so have been able to change the wrong/poor image ones.

 

Following the upgrade I have started to try and set up the track controls but seem to be doing something wrong as I can't get them to react to the original programme numbers, ie point 7 worked by 10, 9 worked by 12 and 10 worked by 13 but 7 stopped working when I deleted 7 on the Z21 so I stopped and shut down the system, any idea what I have done wrong?

 

Whilst I think about it I have signals controlled by a digital servo unit set up as 1 to 4 I have not yet tried to set this up as there are no semaphores on the Z21 can I use a colour light red/green for these servo units?

 

I very much appreciate your help and time answering my questions.

 

regards

 

mike g

Share this post


Link to post
Share on other sites

Yes you can use the colour light as it's just a visual symbol for a switch and it's the address that chooses what it switches.

 

I have no actual idea why locos are resetting to 3, never had that problem with the Z21. I have had a similar incident where all locos on track with an old dcc system where a rogue US spec radio system interfered with our radio based lgb system. Possibly a nearby powerful wifi causing some interference????

Another option might be poor contact at a joint causing the interference or a weak signal. Check all your connections to track and main unit and check everything is tight with no strands of wire causing mini shorts. I'd expect this to affect all locos again though.

Out of interest where abouts are you? Just wondering if you're near any other Z21 members who might be able to have a look. But of a quiet year for exhibiting my layouts due to work commitments but we are at Wimborne in a few weeks and Warley in November using it. Another thing is can the shop you got it from demo it for you to sort problems if close by.

There are some good tutorials on the A&H website

Share this post


Link to post
Share on other sites

Thanks Paul, I think that the rogue Wifi my be the cause as I have 6 sources that come up on the phone and I have had several 'hacks' of my broadband during the last year. I am in mid Hertfordshire near WGC but do not now of many DCC users in the area let alone Z21, the system was bought from Hattons so not really able to help. I did not know about the A&H site so will have a look over the weekend. I have watched the youtube videio's  on the Roco site but did not find them very useful, although that's what decided me to buy the system plus this topic forum.

 

It would not be practical for anybody to look at the system as it's in the loft and the floor is only able to support me, had a visitor many years ago when first built the layout and all the bedroom ceilings cracked so SHMBO said no more visitors! I added additional strength when I put the flooring in but the ceilings are fibre board not plasterboard so the joints opened up with the extra weight! even though I worked in the construction industry and trained as a structural draughtsman.

 

regards

 

mike g

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.